Skip to main content
Mon–Thu 8:30–16:30 · Fri 8:30–16:00 · Bribie Island, QLD
$0.00 0

Cart

No products in the cart.

Same-day dispatch on stocked items - shop nowAfterpay and Klarna available at checkout - shop now

TP-Link JetStream 18-Port Gigabit Smart Switch with 16-Port PoE+

$423.21+ $15 flat-rate shipping Australia-wide

TP-Link JetStream 18-Port Gigabit Smart Switch with 16-Port PoE+, 150W power budget, 2 SFP slots, and Omada SDN integration.

3 in stock

Add to Wishlist
Add to Wishlist

3 in stock

Same-day dispatch order within --:-- for same-day shipping Weekday cutoff
Warehouse availabilityLive
  • QLD1 in stock
  • NSWOut of stock
  • VICOut of stock
  • WAOut of stock
  • SAOut of stock

Need bulk quantities? Contact us for corporate & education orders.

TP-Link JetStream 18-Port Gigabit Smart Switch with 16-Port PoE+. Switch layer: L2/L2+. Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000), Basic switching RJ-45 Ethernet ports quantity: 16. MAC address table: 8000 entries, Switching capacity: 26.78 Gbit/s. Networking standards: IEEE 802.1D, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE…. Power over Ethernet (PoE). Rack mounting, Form factor: 1U

Management features

Switch layer L2/L2+
Quality of Service QoS support Y
Web-based management Y
Cloud-managed Y
ARP inspection Y
Configuring Location Settings CLI Y
System event log Y
MIB support MIB II (RFC1213), Bridge MIB (RFC1493), P/Q-Bridge MIB (RFC2674), Radius Accounting Client MIB (RFC2620), Radius Authentication Client MIB (RFC2618), Remote Ping, Traceroute MIB (RFC2925), Support TP-Link private MIBs, RMON MIB(RFC1757, rmon 1,2,3,9)

Ports & interfaces

Basic switching RJ-45 Ethernet ports quantity 16
Basic switching RJ-45 Ethernet ports type Gigabit Ethernet (10/100/1000)

Network

Networking standards IEEE 802.1D, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3az, IEEE 802.3i, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
10G support N
IP routing Y
Policy-based routing Y
Flow control support Y
Link aggregation Y
Broadcast storm control Y
Rate limiting Y
Auto MDIMDI-X Y
Spanning tree protocol Y
Ethernet LAN data rates 10,100,1000 Mbit/s
Auto-negotiation Y
VLAN support Y

Data transmission

Switching capacity 26.78 Gbit/s
Forwarding rate 26.78 Mpps
MAC address table 8000 entries
Jumbo frames support Y
Jumbo frames 9

Security

DHCP features DHCP client, DHCP relay, DHCP snooping
Access Control List ACL Y
MAC address filtering Y
Static port security Y
SSHSSL support Y
Loop protection Y
BPDU filteringprotection Y
Authentication MAC-based authentication, Port-based authentication

Multicast features

Multicast support Y
Multicast features Multicast forwarding

Design

Rack mounting Y
Form factor 1U
Product colour Black
LED indicators Y
Certification CE, FCC, RoHS

Power

Power source DC/PoE
Power supply included Y
AC input voltage 100 – 240 V
AC input frequency 50/60 Hz

Power over Ethernet PoE

Power over Ethernet PoE Y
Total Power over Ethernet PoE budget 150 W

Operational conditions

Operating temperature T-T 0 – 50 °C
Storage temperature T-T -40 – 70 °C
Operating relative humidity H-H 10 – 90%
Storage relative humidity H-H 5 – 90%

Weight & dimensions

Width 440 mm
Depth 180 mm
Height 44 mm

Packaging data

Cables included LAN (RJ-45)
User guide Y
Package type Box

II354986

Reviews

There are no reviews yet.

Be the first to review “TP-Link JetStream 18-Port Gigabit Smart Switch with 16-Port PoE+”

Your email address will not be published. Required fields are marked *


Product information is sourced directly from suppliers and manufacturers; while we strive for accuracy, descriptions may occasionally contain errors. Ezy P.C. Sales and AusOffice Supplies are not responsible for typographical or photographic inaccuracies, and product images are for illustrative purposes only.

It is the customer's sole responsibility to ensure that the item, hardware component (i.e. Memory, Motherboard, CPU, GPU etc.), or consumable (such as ink and toner cartridges) purchased is fully compatible with their existing equipment, parts, or systems prior to finalising the purchase. We cannot guarantee compatibility with third-party products. In accordance with Australian Consumer Law, returns or refunds are not required to be provided for compatibility errors, incorrect selection, or change of mind once an order is processed.

All prices are in Australian Dollars (AUD), include GST, and are subject to change without notice. We recommend verifying specific details with our team prior to purchase. All sales are subject to our Terms & Conditions and Returns Policy. Delivery charges apply unless otherwise specified. As stocks are limited, we reserve the right to restrict commercial quantities. No further discounts apply to promotional items. These terms do not exclude or limit your rights under the Australian Consumer Law.

Brands we stock

View all brands →
HPSynologyLogitechLenovoTP-LinkSamsungDellUbiquitiJabraASUSQNAPLGAcerCiscoMicrosoftNetCommEpsonAppleDraytekBrotherIntelCanonBelkinKyoceraAMDViewSonicNvidiaBenQGigabyteSeagateMSIWestern DigitalCorsairKingston
Top